Mk3 Indicator stork fault made my relay go nuts.

Please restrict your questions and replies to Capri related technical issues!
Post Reply
Darren Tullett
Posts: 1
Joined: Mon Jan 01, 2018 12:50 pm
Car(s): Capri 1.6 laser 1984

Mk3 Indicator stork fault made my relay go nuts.

Post by Darren Tullett »

Can somebody please help.
My indicator stork was faulty and made the relay buzz. Fitted a replacement stork, but now have no indicators or even ignition. The dash seems dead too. 2 fused were blown, one red and one white. ( replaced those ).
The hazard lights work fine, but no indicators.
Car starts ok.
But no dash, or ignition light. Any ideas please?
1.6 Laser 1984.
What are the relays? 1 x red. 1 x small with a fuse. and another black one. Under the drivers side.
User avatar
Peter-S
Donator
Donator
Posts: 7226
Joined: Mon Jul 28, 2008 7:57 am
Car(s): 1985 Capri 2.0
1983 Capri 2.8i
Location: Kent
Contact:

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by Peter-S »

Have you replaced the switch with the same part? I seem to think there is one for an Escort that looks the same but doesn't have all of the right connections.
ImageBanner by Peter Smith, on Flickr
User avatar
Bug
Posts: 3620
Joined: Sun Jan 04, 2009 3:52 pm
Car(s): Some

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by Bug »

Can't remember exactly on the relays but I think the black one is the indicators?
It has 'blinkgeber' printed on the top, which I think is German for blink giver, or goes blink, or something like that.

And because I'm a boring pedant: it's a stalk.
If you had a Stork in your car you wouldn't see out through all the feathers. ;)
User avatar
Jasonmarie
Donator
Donator
Posts: 4319
Joined: Thu Aug 13, 2015 12:30 am
Car(s): Ford Capri 2.0 Laser Mercury Grey 1987 hobby .
Mercedes Vito tourer 2.1 Big Bus Daily Driver
Location: Kent

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by Jasonmarie »

My horn stopped working last year coming back from the MOT and I have just bought a new stork sorry stalk and not fitted yet got this new on eBay as the Capri club & Tickovers we’re £75 I only paid £20 . I might try taking the old one apart as it must be a dry connection somewhere ?
Ford Capri 2.0 Laser 1987 Mercury Grey ....... :beer:
Mc Tool
Donator
Donator
Posts: 1911
Joined: Sat May 17, 2014 8:34 pm
Car(s): 1980 mk3 capri 2l ohc T9 , Toyota Blade Master 3.5l V6, Paso , 850T,rd400, 900ss
Location: Invercargill New Zealand

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by Mc Tool »

havnt dislodged an earth ?
Sometimes I talk to myself ... and we both have a good laugh
User avatar
Peter-S
Donator
Donator
Posts: 7226
Joined: Mon Jul 28, 2008 7:57 am
Car(s): 1985 Capri 2.0
1983 Capri 2.8i
Location: Kent
Contact:

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by Peter-S »

Jasonmarie wrote: Sat Feb 05, 2022 8:29 pm My horn stopped working last year coming back from the MOT and I have just bought a new stork sorry stalk and not fitted yet got this new on eBay as the Capri club & Tickovers we’re £75 I only paid £20 . I might try taking the old one apart as it must be a dry connection somewhere ?
Have you cleaned the earth connections to the body behind the grill, that seems to be the usual problem
ImageBanner by Peter Smith, on Flickr
User avatar
Jasonmarie
Donator
Donator
Posts: 4319
Joined: Thu Aug 13, 2015 12:30 am
Car(s): Ford Capri 2.0 Laser Mercury Grey 1987 hobby .
Mercedes Vito tourer 2.1 Big Bus Daily Driver
Location: Kent

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by Jasonmarie »

Peter-S wrote: Sat Feb 05, 2022 9:54 pm
Jasonmarie wrote: Sat Feb 05, 2022 8:29 pm My horn stopped working last year coming back from the MOT and I have just bought a new stork sorry stalk and not fitted yet got this new on eBay as the Capri club & Tickovers we’re £75 I only paid £20 . I might try taking the old one apart as it must be a dry connection somewhere ?
Have you cleaned the earth connections to the body behind the grill, that seems to be the usual problem
I will have a play when it’s warmer ? It did work after sometime of pushing down on the horn that’s why I thought it was the stalk at fault .
Ford Capri 2.0 Laser 1987 Mercury Grey ....... :beer:
User avatar
Taff50ish
Donator
Donator
Posts: 676
Joined: Tue Nov 12, 2013 12:08 am
Car(s): Capri 2.8 Injection Special, every few days.
VW Tiguan for daily & boaring runs.
Triumph Speed Triple 1050, Now unfortunately gone...
Triumph 1200 Tiger XCA instead... Now also gone.
Tiger XRT instead... No, gone too...
BMW R1250RS Exec... Try this one out (old man syndrome).

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by Taff50ish »

Hi,

I had this same problem once and it drove me nuts. I had dropped the Steering column once to remove the dash facia, when I put it all back together, nothing on the dash, hazards etc all worked but dead. Turns out I had knocked the twin power plug just under the column so it was actually unplugged, but the black plastic covers made it look like it was still plugged in. If you've been rummaging round here, just check this plug is still plugged in correctly.... its just hanging on the wires.... Best of luck...

John...
User avatar
Jasonmarie
Donator
Donator
Posts: 4319
Joined: Thu Aug 13, 2015 12:30 am
Car(s): Ford Capri 2.0 Laser Mercury Grey 1987 hobby .
Mercedes Vito tourer 2.1 Big Bus Daily Driver
Location: Kent

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by Jasonmarie »

Taff50ish wrote: Sun Feb 06, 2022 12:26 pm Hi,

I had this same problem once and it drove me nuts. I had dropped the Steering column once to remove the dash facia, when I put it all back together, nothing on the dash, hazards etc all worked but dead. Turns out I had knocked the twin power plug just under the column so it was actually unplugged, but the black plastic covers made it look like it was still plugged in. If you've been rummaging round here, just check this plug is still plugged in correctly.... its just hanging on the wires.... Best of luck...

John...
I did have that apart in the summer checking stuff , so I might have done the same , cheers John
Ford Capri 2.0 Laser 1987 Mercury Grey ....... :beer:
User avatar
Andrew 2.8i
Donator
Donator
Posts: 14067
Joined: Sat Jan 25, 2014 7:38 pm
Car(s): '83 2.8 Injection (sunny days only)
'04 Toyota MR2 (owned from new)
Location: Ceredigion
Contact:

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by Andrew 2.8i »

Jasonmarie wrote: Sat Feb 05, 2022 10:41 pm that’s why I thought it was the stalk at fault .
Be careful if you tell any secrets as indicator stalk.... :D :sorry:

Andrew.
Image
User avatar
Jasonmarie
Donator
Donator
Posts: 4319
Joined: Thu Aug 13, 2015 12:30 am
Car(s): Ford Capri 2.0 Laser Mercury Grey 1987 hobby .
Mercedes Vito tourer 2.1 Big Bus Daily Driver
Location: Kent

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by Jasonmarie »

Andrew 2.8i wrote: Sun Feb 06, 2022 5:30 pm
Jasonmarie wrote: Sat Feb 05, 2022 10:41 pm that’s why I thought it was the stalk at fault .
Be careful if you tell any secrets as indicator stalk.... :D :sorry:

Andrew.
You been on the wine gums again :lol: :lol: :lol: :lol: :lol:
Ford Capri 2.0 Laser 1987 Mercury Grey ....... :beer:
Not_Anumber
Donator
Donator
Posts: 893
Joined: Sun Jan 15, 2017 3:54 pm
Car(s): Just sold 1983 2.8 Injection 5 speed. Currently restoring another classic Previously owned 2 Capris. Likely to own another at some point

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by Not_Anumber »

Its important to get the right replacement stalk. There are 2 versions according to age and just to confuse us the wiring connectors are the same so they appear interchangeable plus there is very little to distinguish the 2 types- however they are wired completely differently internally and are definitely not interchangeable. Replace a faulty stalk with the wrong version and it will make the problem a lot worse.
User avatar
Jasonmarie
Donator
Donator
Posts: 4319
Joined: Thu Aug 13, 2015 12:30 am
Car(s): Ford Capri 2.0 Laser Mercury Grey 1987 hobby .
Mercedes Vito tourer 2.1 Big Bus Daily Driver
Location: Kent

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by Jasonmarie »

I just put a BMW badge on the Capri as they don’t use bloody indicator’s :lol: :lol: :lol:
Ford Capri 2.0 Laser 1987 Mercury Grey ....... :beer:
User avatar
pbar
Posts: 6731
Joined: Thu Jun 07, 2012 6:29 pm
Car(s): Capri 2.0 Laser, frequent driver.
Location: North-West

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by pbar »

Jasonmarie wrote: Thu Mar 03, 2022 11:53 pm I just put a BMW badge on the Capri as they don’t use bloody indicator’s :lol: :lol: :lol:

Hehe, funny :) If you don't have a BMW badge then use an Audi one, they're even worse. So many bad Audi drivers around.
User avatar
Jasonmarie
Donator
Donator
Posts: 4319
Joined: Thu Aug 13, 2015 12:30 am
Car(s): Ford Capri 2.0 Laser Mercury Grey 1987 hobby .
Mercedes Vito tourer 2.1 Big Bus Daily Driver
Location: Kent

Re: Mk3 Indicator stork fault made my relay go nuts.

Post by Jasonmarie »

pbar wrote: Fri Mar 04, 2022 10:20 am
Jasonmarie wrote: Thu Mar 03, 2022 11:53 pm I just put a BMW badge on the Capri as they don’t use bloody indicator’s :lol: :lol: :lol:

Hehe, funny :) If you don't have a BMW badge then use an Audi one, they're even worse. So many bad Audi drivers around.
I agree and roundabouts really get me as they just don’t get in the right lane or signal :lol: :banghead:
Ford Capri 2.0 Laser 1987 Mercury Grey ....... :beer:
Post Reply