Fuse 2

Please restrict your questions and replies to Capri related technical issues!
Post Reply
foley8814
Posts: 5
Joined: Mon Jul 22, 2019 4:57 pm
Car(s): Ford capri 2.0 modified

Fuse 2

Post by foley8814 » Sat Aug 24, 2019 6:36 pm

Hi
Fuse 2 keeps blowing on my mk3 1986 capri,evreytime I put lights on the, only thing I've changed is the light fuse box on the bulk head and cleaned the rear lights plastic covers I never took out the rear lights as a hole unit it's weird! Thanks for your advice.

User avatar
Peter-S
Donator
Donator
Posts: 6702
Joined: Mon Jul 28, 2008 7:57 am
Car(s): 1985 Capri 2.0
1983 Capri 2.8i
Location: Kent
Contact:

Re: Fuse 2

Post by Peter-S » Sat Aug 24, 2019 9:24 pm

When you say the light fuse box is that the relay - small metal box on the passenger side under the bonnet?
Anyway, I'd start by putting the old one back if you haven't already and see if that solves the problem.
Rear lights can also be temperamental so is it possible you have disturbed someone else's previous repair and maybe something is now shorting to earth?
ImageBanner by Peter Smith, on Flickr

foley8814
Posts: 5
Joined: Mon Jul 22, 2019 4:57 pm
Car(s): Ford capri 2.0 modified

Re: Fuse 2

Post by foley8814 » Sat Aug 24, 2019 10:00 pm

I've put old one back on still blowing fuse yes sorry i mean the relay, been fine then this, check all the earth's all seem fine have also checked rear lights no cracks.
Thanks for your reply

Mr B
Posts: 184
Joined: Fri Dec 09, 2016 9:07 am
Car(s): Four 3 litre Capri's and 2 Mark 1 GXL's

Re: Fuse 2

Post by Mr B » Sat Aug 24, 2019 10:09 pm

If memory serves the relay has 3 plugs that connect to it, the big one in the middle (4 connections) and 1 plug either side of it, it is possible to get the outer plugs mixed up as the loom that feeds them is long enough to make them interchangeable, don't whether getting them mixed up would cause a short but worth a look

Wayne

foley8814
Posts: 5
Joined: Mon Jul 22, 2019 4:57 pm
Car(s): Ford capri 2.0 modified

Re: Fuse 2

Post by foley8814 » Sat Aug 24, 2019 10:51 pm

Cheers checked that first, I've relised it does it when I turn ignition on, no dash lights at all now but all others work in wipers lights and reverse just no dash lights and blowing fuse when I turn ignition on

foley8814
Posts: 5
Joined: Mon Jul 22, 2019 4:57 pm
Car(s): Ford capri 2.0 modified

Re: Fuse 2

Post by foley8814 » Sun Aug 25, 2019 8:53 am

I bridged the dimmer switch a while ago and it's been fine but now the wire burnt out when it's not connected it doesn't blow the fuse??

foley8814
Posts: 5
Joined: Mon Jul 22, 2019 4:57 pm
Car(s): Ford capri 2.0 modified

Re: Fuse 2

Post by foley8814 » Sun Aug 25, 2019 1:00 pm

Well it seems to be a burnt out light bulb wire going to the clock the bulb wire had no bulb on it and wire was melted! I'm assuming it's that since its been up plugged dash lights and no fuse blowing!

Post Reply