Temp sensor bullet connector

Please restrict your questions and replies to Capri related technical issues!
tazla
Posts: 337
Joined: Tue Mar 10, 2015 7:25 pm
Car(s): Mk2 3.0s stardust silver

Temp sensor bullet connector

Post by tazla » Tue Jun 18, 2019 8:29 pm

Hi chaps im doing a little clean up of the engine bay as its got a bit tatty since my resto a couple of years back ,with the heat of the engine and a bit of condensation and the car been sat in a lock up has made a few things a bit tatty so i wonder if anyone can help, the wire/bullet conector which connects/push fits to the temp sensor is missing /bodged on my car. where can i get a connector with wire attached and also the rev cable where it connects to the linkage to the carb has surface rust on.do i paint it or bare metal it and grease it ,galvanised paint etc. i polished it up before but it gets surface rust on after a while.any help is much appreciated.cheers mel

User avatar
pbar
Posts: 5698
Joined: Thu Jun 07, 2012 6:29 pm
Car(s): Capri 2.0 Laser, frequent driver.
Location: North-West

Re: Temp sensor bullet connector

Post by pbar » Wed Jun 19, 2019 6:16 am

I'd try CapriGear for your connector - https://caprigear.co.uk/

As a regular user of this forum you can PM him on here too, I've found he replies very quickly to help.

tazla
Posts: 337
Joined: Tue Mar 10, 2015 7:25 pm
Car(s): Mk2 3.0s stardust silver

Re: Temp sensor bullet connector

Post by tazla » Wed Jun 19, 2019 7:48 pm

Cheers il give him a go.ive had a few bits off him before.

User avatar
Jasonmarie
Donator
Donator
Posts: 3010
Joined: Thu Aug 13, 2015 12:30 am
Car(s): Ford Capri 2.0 Laser Mercury Grey 1987 hobby
Mercedes Vito Traveline 2.2 Big Bus Daily Driver
Location: Kent

Re: Temp sensor bullet connector

Post by Jasonmarie » Wed Jun 19, 2019 9:24 pm

I agree with Paul Martin will send you the right one as well :beer:
Ford Capri 2.0 Laser 1987 Mercury Grey ....... :beer:

Not_Anumber
Donator
Donator
Posts: 596
Joined: Sun Jan 15, 2017 3:54 pm
Car(s): 2.8 Injection 1983, early 5 speed. Slowly restoring a 1979 MGB + a 1964 Honda 250 twin. Previously owned 2 Capris.

Re: Temp sensor bullet connector

Post by Not_Anumber » Thu Jun 20, 2019 1:25 pm

Is Martin back from his holidays yet ?

User avatar
Jasonmarie
Donator
Donator
Posts: 3010
Joined: Thu Aug 13, 2015 12:30 am
Car(s): Ford Capri 2.0 Laser Mercury Grey 1987 hobby
Mercedes Vito Traveline 2.2 Big Bus Daily Driver
Location: Kent

Re: Temp sensor bullet connector

Post by Jasonmarie » Thu Jun 20, 2019 3:06 pm

Don’t know he went to that nudist beach in Spain for two weeks to top up his tan . Must be back now :beer:

I am sure that’s what I read on his Facebook page :lol:
Ford Capri 2.0 Laser 1987 Mercury Grey ....... :beer:

User avatar
andyd
Posts: 6533
Joined: Wed Aug 20, 2014 10:43 am
Car(s): 1984 2.8 Injection
Location: Devon

Re: Temp sensor bullet connector

Post by andyd » Thu Jun 20, 2019 4:11 pm

Yes Martin is back :cheers:

User avatar
Andrew 2.8i
Donator
Donator
Posts: 12641
Joined: Sat Jan 25, 2014 7:38 pm
Car(s): '83 2.8 Injection (sunny days only)
'04 Toyota MR2 (owned from new)
Location: Ceredigion
Contact:

Re: Temp sensor bullet connector

Post by Andrew 2.8i » Thu Jun 20, 2019 8:12 pm

Jasonmarie wrote:
Wed Jun 19, 2019 9:24 pm
I agree with Paul Martin
Me too. He really knows his stuff on Flog It. :lol:

I looked everywhere for a replacement bullet connector for the temp sender, but I just couldn't find one that was a good match for the original.
Luckily Martin was able to supply one with a short length of the correct wire attached.
A secondhand one is your only hope if you strive for an original style item

Andrew.
Image

User avatar
Jasonmarie
Donator
Donator
Posts: 3010
Joined: Thu Aug 13, 2015 12:30 am
Car(s): Ford Capri 2.0 Laser Mercury Grey 1987 hobby
Mercedes Vito Traveline 2.2 Big Bus Daily Driver
Location: Kent

Re: Temp sensor bullet connector

Post by Jasonmarie » Thu Jun 20, 2019 10:33 pm

Had you down as a Dickson real deal Andrew :lol:
Ford Capri 2.0 Laser 1987 Mercury Grey ....... :beer:

User avatar
Andrew 2.8i
Donator
Donator
Posts: 12641
Joined: Sat Jan 25, 2014 7:38 pm
Car(s): '83 2.8 Injection (sunny days only)
'04 Toyota MR2 (owned from new)
Location: Ceredigion
Contact:

Re: Temp sensor bullet connector

Post by Andrew 2.8i » Fri Jun 21, 2019 5:25 am

Jasonmarie wrote:
Thu Jun 20, 2019 10:33 pm
Had you down as a Dickson real deal Andrew :lol:
Gotta love The Duke.
What a Bobby Dazzler! :D

Andrew.
Image

tazla
Posts: 337
Joined: Tue Mar 10, 2015 7:25 pm
Car(s): Mk2 3.0s stardust silver

Re: Temp sensor bullet connector

Post by tazla » Fri Jun 21, 2019 5:22 pm

Been it touch and he has one.ordered summat else as well . 8-)

80s-new-man
Posts: 50
Joined: Tue May 21, 2019 11:21 am
Car(s): Ford Capri 2.9 Cosworth Dec 1984, reg. Feb 1985
Location: Suffolk

Re: Temp sensor bullet connector

Post by 80s-new-man » Mon Jul 01, 2019 10:15 am

Quick one..my temp sensor died on my BOA Cossie and I replaced it with a genuine Ford item for the BOA, mine had a kind of screw on bullet, which was quite rusted so I cleaned it up with steel wool and WD40 before screwing it back on the new sensor. However she now only reads max the bottom level on the gauge even when full operating temperature...(before , she went to the second one up)

Not sure why if it’s a new sensor, or could it be the bullet screw connection that is on its way out....
Cheers
:beer:
Stu
Capri 2.9i Special Dec 1984, reg Feb 1985

80s-new-man
Posts: 50
Joined: Tue May 21, 2019 11:21 am
Car(s): Ford Capri 2.9 Cosworth Dec 1984, reg. Feb 1985
Location: Suffolk

Re: Temp sensor bullet connector

Post by 80s-new-man » Mon Jul 01, 2019 10:15 am

:o sorry that should read BOB not BOA
Cheers
:beer:
Stu
Capri 2.9i Special Dec 1984, reg Feb 1985

80s-new-man
Posts: 50
Joined: Tue May 21, 2019 11:21 am
Car(s): Ford Capri 2.9 Cosworth Dec 1984, reg. Feb 1985
Location: Suffolk

Re: Temp sensor bullet connector

Post by 80s-new-man » Thu Jul 25, 2019 8:07 pm

:banghead: I changed the sensor for a brand new one..the bullet connection with a proper one, mmm she still sits on the lowest possible reading even after a 20 mile run in 95 degree heat....could the wire be on its way out?
Cheers
:beer:
Stu
Capri 2.9i Special Dec 1984, reg Feb 1985

User avatar
Andrew 2.8i
Donator
Donator
Posts: 12641
Joined: Sat Jan 25, 2014 7:38 pm
Car(s): '83 2.8 Injection (sunny days only)
'04 Toyota MR2 (owned from new)
Location: Ceredigion
Contact:

Re: Temp sensor bullet connector

Post by Andrew 2.8i » Thu Jul 25, 2019 8:30 pm

80s-new-man wrote:
Thu Jul 25, 2019 8:07 pm
:banghead: I changed the sensor for a brand new one..the bullet connection with a proper one, mmm she still sits on the lowest possible reading even after a 20 mile run in 95 degree heat....
Did you get the one with the white collar?

Andrew.
Image

80s-new-man
Posts: 50
Joined: Tue May 21, 2019 11:21 am
Car(s): Ford Capri 2.9 Cosworth Dec 1984, reg. Feb 1985
Location: Suffolk

Re: Temp sensor bullet connector

Post by 80s-new-man » Tue Jul 30, 2019 5:05 pm

Hi Andy, It’s one with , like a 90 degree black connector, from a scrap 2.8i ..
I have changed the wire, as I noticed that the wire when I cut it, was rather black inside, so that didn’t look right.
Gonna take her out for a 10 mile run when I take my daughter to work tonight so will see what happens..

Cheers
Cheers
:beer:
Stu
Capri 2.9i Special Dec 1984, reg Feb 1985

User avatar
Andrew 2.8i
Donator
Donator
Posts: 12641
Joined: Sat Jan 25, 2014 7:38 pm
Car(s): '83 2.8 Injection (sunny days only)
'04 Toyota MR2 (owned from new)
Location: Ceredigion
Contact:

Re: Temp sensor bullet connector

Post by Andrew 2.8i » Tue Jul 30, 2019 5:59 pm

80s-new-man wrote:
Tue Jul 30, 2019 5:05 pm
Gonna take her out for a 10 mile run when I take my daughter to work tonight so will see what happens..
Good luck, hopefully that will work.
The sensor must be one with a white collar below where the bullet connector attaches, like this one:
Image
If that collar is any colour other than white, it will give an incorrect temperature reading.

Andrew.
Image

80s-new-man
Posts: 50
Joined: Tue May 21, 2019 11:21 am
Car(s): Ford Capri 2.9 Cosworth Dec 1984, reg. Feb 1985
Location: Suffolk

Re: Temp sensor bullet connector

Post by 80s-new-man » Thu Aug 01, 2019 7:03 am

Andy thanks..
I think all along I had misunderstood- I thought the actual connector with wire had to be white. In fact it’s black.
The connector ON the actual sensor...well, that is a turquoise colour as I had ordered it for the Granada/Scorpio, thinking that is the correct one for her engine.
So now I’m gonna order a sensor with the white collar...hopefully that will put it right!

Thanks!
Stu
:axe:
Cheers
:beer:
Stu
Capri 2.9i Special Dec 1984, reg Feb 1985

User avatar
Andrew 2.8i
Donator
Donator
Posts: 12641
Joined: Sat Jan 25, 2014 7:38 pm
Car(s): '83 2.8 Injection (sunny days only)
'04 Toyota MR2 (owned from new)
Location: Ceredigion
Contact:

Re: Temp sensor bullet connector

Post by Andrew 2.8i » Thu Aug 01, 2019 3:40 pm

80s-new-man wrote:
Thu Aug 01, 2019 7:03 am
So now I’m gonna order a sensor with the white collar...hopefully that will put it right!
Hang about Stu, I've only just noticed that you've got a 2.9 Cosworth engine, not a standard Capri engine. It would be best to check with somebody like Tickover to determine which is the correct sensor for your particular application.

Andrew.
Image

80s-new-man
Posts: 50
Joined: Tue May 21, 2019 11:21 am
Car(s): Ford Capri 2.9 Cosworth Dec 1984, reg. Feb 1985
Location: Suffolk

Re: Temp sensor bullet connector

Post by 80s-new-man » Thu Aug 01, 2019 7:10 pm

Ah well that’s ok Andy, I ordered one of the white/grey collar from fleabay for 8 quid , now I’ll have both !
Cheers
:beer:
Stu
Capri 2.9i Special Dec 1984, reg Feb 1985

Post Reply