Motocraft plugs

Please restrict your questions and replies to Capri related technical issues!
tazla
Posts: 148
Joined: Tue Mar 10, 2015 7:25 pm
Car(s): Mk2 3.0s stardust silver

Motocraft plugs

Postby tazla » Mon Jan 01, 2018 11:01 pm

Happy new year capri folk.
Had a strange one over chrissy.the car started to misfire slightly.running a bit rough.dizzy cap ,rota arm.points,condensor,coil .ngk plugs all new.mmmmmm
So i checked the points.theyre ok.checked plugs .sooty but dry.
Got the timing gun out.connected it up to no 1 plug lead.and the gun wouldnt flash.so.i pulled no 1 lead off and apresto .no change what so ever.im thinking oh sh1t!
Down on a cylinder.
Took the plug out ,replaced it with a motocraft one and timing light now works .yaaaay.panic over.so has anyone else had this problem a sparkplug failing.and are motocraft plugs any good as i think im gonna change to them.or is it a case of bad luck.
Get another set of ngk,s and put it down to experience.
Cheers mel

User avatar
Noel
Donator
Donator
Posts: 326
Joined: Thu May 19, 2011 7:57 pm
Car(s): Capri 2.8i
Range Rover
Jaguar X Type.
Location: Twickenham

Re: Motocraft plugs

Postby Noel » Tue Jan 02, 2018 9:37 am

I think you have just been unlucky with that NGK. Have used them myself a lot, and not had problems.
That said my 2.8i has Motorcrafts in it at the moment and they have been fine too.

tazla
Posts: 148
Joined: Tue Mar 10, 2015 7:25 pm
Car(s): Mk2 3.0s stardust silver

Re: Motocraft plugs

Postby tazla » Tue Jan 02, 2018 5:24 pm

I think so too.ive took the motocraft ones out and put new ngk,s back in haha.ive had the car in and out today.trying to set the timing/ carb up.finally just got her back in .cleaned /dried.runs lovely. Now im not bleeding messing with it anymore.dont know why i messed with it in the first place ha.


Return to “Q & A”

Who is online

Users browsing this forum: Bing [Bot] and 12 guests