Please please please help!

Please restrict your questions and replies to Capri related technical issues!
anicola02
Posts: 32
Joined: Fri Nov 02, 2012 4:19 pm
Car(s): Fiat Punto 1.2 16v, 4-2-1 De-cat, Custom air induction (by GSR), 8v flexy pipe, Custom Centre Exhaust, "GO" Interior, Port Polish head and throttle body, 17" Sabre Alloys, AK FK Coilovers, Tinted Windows.... Air Freshener :D

Please please please help!

Postby anicola02 » Sun Jul 16, 2017 12:19 pm

Hi guys! I've had a few recent posts on here thanks so much for he replys! You've all helped loads!

I've recently refurbished my capri, new paint job, new pistons, valves etc.. spent quite a bit of money on it.

Anyways I drove 500 miles and had it tuned, drove another 100 miles and now it starts for about 20 seconds and just conkes out... I've recently replaced the starter motor , then the speedo cable and now the oil pressure cable and had to polish some of the earth terminals (turns out I didn't need to replace the starter haha)
Does anyone have any advice to do before I take it In to the garage!
Really annoyed as spent 5k doing it up for summer and now it just sits there breaking down every 5 seconds :(

340truck
Donator
Donator
Posts: 3333
Joined: Mon Jul 28, 2008 8:00 am
Car(s): Rat - GONE
2.8 - GONE
Volvo - GONE
Left with 1.6 fezza as daily to have a bit of fun with.
Hopefully a sierra arrives soon.
Location: Haverhill Suffolk

Re: Please please please help!

Postby 340truck » Sun Jul 16, 2017 6:14 pm

Engine type?
Image

User avatar
pbar
Posts: 4698
Joined: Thu Jun 07, 2012 6:29 pm
Car(s): Capri 2.0 Laser, frequent driver.
Location: North-West

Re: Please please please help!

Postby pbar » Mon Jul 17, 2017 6:37 am

anicola02 wrote:
Anyways I drove 500 miles and had it tuned, drove another 100 miles and now it starts for about 20 seconds and just conkes


Could be millions of things to be honest from that description, but if it was ok before you had it 'tuned', and now it isn't, I would ask them exactly what they did and tampered with, and start there.

anicola02
Posts: 32
Joined: Fri Nov 02, 2012 4:19 pm
Car(s): Fiat Punto 1.2 16v, 4-2-1 De-cat, Custom air induction (by GSR), 8v flexy pipe, Custom Centre Exhaust, "GO" Interior, Port Polish head and throttle body, 17" Sabre Alloys, AK FK Coilovers, Tinted Windows.... Air Freshener :D

Re: Please please please help!

Postby anicola02 » Tue Jul 18, 2017 1:10 am

340truck wrote:Engine type?


How the hell could I not put the most important thing gun the description?! Haha it's a 2l pinto...

Engine was fine after the tune up untill it sat there for two weeks. I started it one day it runs fine then it shut off and didn't turn back on. But it will start up again if you leave it a day but, again, after 20-30 seconds it'll start misfiring and shut off again :banghead:

User avatar
pbar
Posts: 4698
Joined: Thu Jun 07, 2012 6:29 pm
Car(s): Capri 2.0 Laser, frequent driver.
Location: North-West

Re: Please please please help!

Postby pbar » Tue Jul 18, 2017 6:12 am

There really isn't enough info for someone to diagnose what the issue could be. Maybe crud in the carb blocking the fuel flow? Especially if they have messed with it with 'tuning' it.

Paul G
Posts: 739
Joined: Fri Jul 03, 2015 5:21 pm
Car(s): MK 3 3.0S needing restoration, 2.0S, 1.6 Laser (nearly ready), Fiesta mK2 pop plus, Skoda Octavia VRS, Rover SD1 Vitesse.
Location: High Wycombe

Re: Please please please help!

Postby Paul G » Tue Jul 18, 2017 8:27 am

Could it be a blocked fuel pick up in the tank? I recently had this with my kit car after it had been laid up with stale fuel still in the tank. Even with fresh fuel it drove to an mot test OK then broke down twicce on the way home. I isolated the problem down to the fuel pick up and the pick up was blocked. Cleaned it out enough to get home then completely cleaned the pick up and blew out the front to rear pipe with compressed air. Also fitted an inline fuel filter.

Your problem could be a similar one if the car has been laid up for any length of time. When it cuts out take the top off the carb and see if there is fuel in there.

Also is your condenser OK in the distributor?

User avatar
Peter-S
Donator
Donator
Posts: 6153
Joined: Mon Jul 28, 2008 7:57 am
Car(s): 1985 Capri 2.0
1983 Capri 2.8i
Location: Kent
Contact:

Re: Please please please help!

Postby Peter-S » Tue Jul 18, 2017 8:48 am

anicola02 wrote:
340truck wrote:Engine type?


How the hell could I not put the most important thing gun the description?! Haha it's a 2l pinto...

Engine was fine after the tune up untill it sat there for two weeks. I started it one day it runs fine then it shut off and didn't turn back on. But it will start up again if you leave it a day but, again, after 20-30 seconds it'll start misfiring and shut off again :banghead:


Could be a sticking float needle in the carb so worth checking and cleaning that as well.
ImageImageImage

Not_Anumber
Donator
Donator
Posts: 241
Joined: Sun Jan 15, 2017 3:54 pm
Car(s): 2.8 Injection 1983 weekend use. Restoring:1980 MGB GT + 1964 Honda 250 bike. Previously owned 2 Capris.

Re: Please please please help!

Postby Not_Anumber » Tue Jul 18, 2017 9:56 am

Just a thought, check the coil is working. I once had a similar problem after someone else worked on a Pinto engined Capri I had some years ago. He had somehow connected the coil to a full 12 volt feed rather than it's usual lower voltage feed via the ballast resistor. The coil overheated almost immediately when fired up, wouldn't restart unless left for quite some time to cool down again. Connecting it to the correct feed sorted it in seconds once i had realised.

User avatar
Major_Tom
Posts: 7003
Joined: Mon Jul 28, 2008 8:21 am
Car(s): Hot 2.0S
Location: Cambridge

Re: Please please please help!

Postby Major_Tom » Wed Aug 02, 2017 4:28 pm

What happened with this?
My car isn't stupid.... it's MENTAL.

User avatar
Jasonmarie
Donator
Donator
Posts: 464
Joined: Thu Aug 13, 2015 12:30 am
Car(s): Ford Capri 2.0 Laser Mercury Grey 1987 hobby
Mercedes Vito Traveline 2.2 Big Bus Daily Driver
Admin Member for 11 years on the smaxownersclub
Location: Kent

Re: Please please please help!

Postby Jasonmarie » Thu Aug 03, 2017 9:42 am

If it's for a pinto engine I wonder if a pipe has come of on the carb as it sounds like just a air pipe has come off .

Not_Anumber
Donator
Donator
Posts: 241
Joined: Sun Jan 15, 2017 3:54 pm
Car(s): 2.8 Injection 1983 weekend use. Restoring:1980 MGB GT + 1964 Honda 250 bike. Previously owned 2 Capris.

Re: Please please please help!

Postby Not_Anumber » Thu Aug 03, 2017 10:23 am

It would be good if anicola02 could let us know how he got in.

Asking for ideas is great but actually reporting back on how faults were fixed is the means by which we all learn.


Return to “Q & A”

Who is online

Users browsing this forum: Bing [Bot] and 18 guests