Ignition light earth problem to alternator

Please restrict your questions and replies to Capri related technical issues!
Post Reply
David1979
Posts: 2
Joined: Sat Feb 11, 2017 10:41 pm
Car(s): Ford Capri mk2 1977 2.0 205 5 speed + other mods
Famous vauxhall Cavalier mk2 1987 2.0 glsI

Ignition light earth problem to alternator

Post by David1979 » Mon Mar 20, 2017 11:21 pm

Hi everyone new to the forum and this is my first post! OK, 2 years ago I bought a 1977 mk2 capri 2.0 pinto that's been off the road since 1991/92, approx 2/3 completed & which someone's put a lot of good hard work into, I'm just finishing it off now ready for the 1st MOT in 26 years. So I've overcome all sorts of puzzles with this car lol including why it had mk3 rear lights in it and why won't the rightful mk2 lights I bought for it work right? Oh someone's fitted a mk3 loom! And why won't the heater fan work? It was seized! But didn't help that there wasn't any power going to it, oh someone's fitted a fuse box with no solid link between the live feed of fuse 5-6! (Now all sorted!) And its these forums that have helped me solve all these issues absolutely fantastic! So, anyway the thing now is that the red ignition light on dash is ON 'all' the time, with key out of barrel!?? and when ignition is then turned on (but not started!) the red iggy light goes OFF!? when engine running it stays off as normal. So basically this light is ar*e about t*t. Now I know about the old blue wire to the alternator (that goes to red dash light)t hat's an earth 1 minute and live the next (so as to turn on/off said red dash light), so, I ran a temp earth wire to blue wire terminal at the alternator plug and hey great light was on with ignition and off when key removed! Normality! OK, so far so good, then wire removed and great the light is now still working as it should! on when iggy on, off when iggy off. Great! Cycle it many.times to check and its still all good, but - wait for a couple mins or turn your back then I go to try again and... back to the way it was, red iggy light on ALL the time (key removed) and off when key turned to iggy on! and battery has to be disconnected or will (probably) drain because of it. Now, there was a spare alternator in the boot so tried em both but same thing, took one of em yesterday to local alty/starter motor rebuilder expert man I've used loads before and he's just today reported all is normal with the alternator, and probably a fault with your wiring, so now I'm stumped!!! Can anyone help?? Thanks in advance, and i WILL be reporting what i did to solve it (I hope!) So as to help others in future who may have this problem!?!? Thanks everyone, David. P.S. this blue wire reports the status by turning on / off the red ignition light on the dash, and apparently is an earth when alty not spinning then becomes live when alty starts to spin (so I have read!) And this is what simply illuminates/deluminates the red dash iggy light letting you know whats going on, So by running my own temp earth to this blue wire contact on the alty, i have some success, so long as engine not running, because u cant leave it there or else soon as alty is spinning with engine this earth will become live and fry stuff! So i hope u see my dilemma!? Thanks again, David.

User avatar
stevemarl
Donator
Donator
Posts: 4549
Joined: Wed Jul 11, 2012 6:31 pm
Car(s): Capri 1.6 laser

Re: Ignition light earth problem to alternator

Post by stevemarl » Tue Mar 21, 2017 11:04 am

Can`t explain what`s causing your symptoms (other than someone`s butchered the wiring) but it`s important to understand how Ign light works before you can sort it. Basically the ign wire goes to the alternator. When the Alt is not turning, no output, 0v, the bulb can flow to earth THROUGH the alternator. Once the alt is running, it then has 12v on what was the `earthey` side of your ign bulb; 12v on each side = zero current flow, bulb out. (depending on poor earths, current demand etc, there may still be a slight difference between the B+ and Alt which is why it may glow dimly with all the lights on.)
The point I`m trying to make is that the Ign bulb is not switched on/off as such, it SHOULD be comparing 2 violtages (B+ & Alt) when these are equal it goes out.
Hope that helps
Steve

David1979
Posts: 2
Joined: Sat Feb 11, 2017 10:41 pm
Car(s): Ford Capri mk2 1977 2.0 205 5 speed + other mods
Famous vauxhall Cavalier mk2 1987 2.0 glsI

Re: Ignition light earth problem to alternator

Post by David1979 » Sun Nov 22, 2020 2:03 pm

Hi, so 3 years later after not messing with the Capri really., apart from a the head off for a reconditioning and unleaded conversion last year, I've decided to approach this problem again, and as promised, posting the result! Big thanks to "stevemarl" for his reply, Thanks Steve . So, today I decided to unravel all the tape on the loom from alternator, and just approx 8" from the plug someone has scotchlocked a red wire from the blue alty wire (tell tale lamp for ign) to battery positive!!? removed this wire and bingo! ignition light works exactly as it should. off when off, on when on (engine not running) and back off when engine started.
So problem solved!! Yayyy! I'm still Interested to know why on earth (literally, "on an earth"!) someone has done that? Answers on a postcard, as they say, or just on here will do! Any ideas anyone?
Also, Capri is available to buy if anyone is interested. Fully roadworthy and converted to unleaded. been off the road since 1991 but I've just driven 30 miles in it to test it out. Anyone Interestested can PM me.
Thanks, David.

Paul G
Posts: 1603
Joined: Fri Jul 03, 2015 5:21 pm
Car(s): MK 3 3.0S needing restoration, 2.0S, 1.6 Laser (nearly ready), Fiesta mK2 pop plus, Skoda Octavia VRS,
Location: High Wycombe

Re: Ignition light earth problem to alternator

Post by Paul G » Sun Nov 22, 2020 3:27 pm

Well done David on finding the issue. Rectifying other people's bodges is the worst thing you can have to do when renovating a car.

Mc Tool
Donator
Donator
Posts: 1396
Joined: Sat May 17, 2014 8:34 pm
Car(s): 1980 mk3 capri 2l ohc T9 , Toyota Blade Master 3.5l V6, Paso , 850T,rd400, 900ss
Location: Invercargill New Zealand

Re: Ignition light earth problem to alternator

Post by Mc Tool » Sun Nov 22, 2020 5:33 pm

It would be interesting to follow the train of thought of the person who did that ......why ?
you gotta make the most :cheers: :cigar: :burnout: out of your 20's, 30's, and 40's coz when you hit 50 the "engine check" light comes on. :?

User avatar
stevemarl
Donator
Donator
Posts: 4549
Joined: Wed Jul 11, 2012 6:31 pm
Car(s): Capri 1.6 laser

Re: Ignition light earth problem to alternator

Post by stevemarl » Mon Nov 23, 2020 10:42 pm

David1979 wrote:
Sun Nov 22, 2020 2:03 pm
Big thanks to "stevemarl" for his reply, Thanks Steve
My absolute pleasure! That`s brilliant news - and thanks so much for giving the update!

Post Reply