Going slightly mad

You can RANT and RAVE to your hearts content here instead of clogging up the Q&A Technical Forum!
Report any offensive posts to [email protected]
Post Reply
Cosmicbike
Posts: 207
Joined: Thu Feb 21, 2019 9:47 pm
Car(s): Ford Capri 1.6 Laser Resto Project
Location: Egham, Surrey

Going slightly mad

Post by Cosmicbike » Thu Aug 08, 2019 3:56 pm

If it's not one problem it's another. Spent the evening yesterday and afternoon today bolting all the external bits back on to the Laser, nothing like finished and it shows, but it'll get me to Brooklands.
Quick light check, all good but when you flash the headlights they don't, instead we indicate left :lol:
After a methodical approach to fixing the misfire, we now seem to be in a good place. Except now we hunt between 700 - 1800 rpm on idle, that's new :roll: Foot on go go pedal makes it smooth out with the occasional hiccup at 2000rpm, methinks air getting in somewhere.

Shoved it back in the garage, get a 5 day break for work now. I only have 1 more day to play, I've a horrible feeling the old tart may not make it to the 50th party :(

Caprigear
Donator
Donator
Posts: 2297
Joined: Thu Jan 27, 2011 9:14 pm

Re: Going slightly mad

Post by Caprigear » Thu Aug 08, 2019 7:14 pm

The lights issue may be a knackered indicator stalk , they're prone to breaking.
Image

Mr B
Posts: 211
Joined: Fri Dec 09, 2016 9:07 am
Car(s): Four 3 litre Capri's and 2 Mark 1 GXL's

Re: Going slightly mad

Post by Mr B » Thu Aug 08, 2019 10:32 pm

Caprigear wrote:
Thu Aug 08, 2019 7:14 pm
The lights issue may be a knackered indicator stalk , they're prone to breaking.
:agree: Had this happen a few times over the years

Wayne

Post Reply